跳到主要内容
版本:v2.9 (Preview)

Helm 版本要求

本文介绍 Helm 的要求。Helm 是用于把 Rancher 安装在高可用 Kubernetes 集群上的工具。

我们已针对 Helm 3 更新了安装指南。如果你使用 Helm 2 进行安装,请参见 Helm 2 迁移到 Helm 3 文档本文提供了较早的使用 Helm 2 的 Rancher 高可用安装指南的副本。如果你如果无法升级到 Helm 3,可以使用这个说明安装。

危险

Helm v2 support is deprecated as of the Rancher v2.7 line and will be removed in Rancher v2.9.

  • 如需安装或升级 Rancher 2.5,请使用 Helm 3.2.x 或更高版本。
  • Kubernetes 1.16 要求 Helm 2.16.0 或更高版本。如果使用的是默认 Kubernetes 版本,请参见发行说明获取所使用的 RKE 版本。
  • 请不要使用 Helm 2.15.0,因为这个版本有转换/比较数字的问题。
  • 请不要使用 Helm 2.12.0,因为该版本有 cert-manager 的兼容问题。